Kategori arşivi: Genel

Cisco Port Mirroring Yapılandırma

Port mirroring, switchte bir port üzerine gelen trafiği başka bir porta kopyalama işlemidir. Genellikle gelen trafiği izlemek için port mirroring yapılmaktadır. Bu işlemi switchlerde port veya vlan bazlı olarak yapabiliriz. Bu yazıda Cisco switchlerde bu işlemin nasıl yapılacağını detaylı bir şekilde anlatacağız.

1-) İlk olarak Cisco switchte port bazlı mirroring işlemi için örnek uygulama yapalım. Bunun için aşağıdaki komutları inceleyelim;

enable
conf term
monitor session 1 source interface fast0/1
monitor session 1 destination interface fast0/2

Burada switchte fastEthernet0/1 portuna gelen trafiği fastEthernet0/2 portuna kopyalamış olduk.

2-) Port aralığını da farklı bir porta kopyalayabiliriz. Bunun için aşağıdaki örneği inceleyelim;

monitor session 2 source interface fast0/5 - 9
monitor session 2 destination interface fast0/10

3-) Vlan bazlı kopyalama da yapabilmemiz mümkündür. Bu işlem için aşağıdaki örneği inceleyelim;

monitor session 3 source vlan 10 - 14
monitor session 3 destination interface fast0/15

Burada switchte vlan 10 ile 14 aralığını fastEthernet0/15 portuna kopyalamış olduk.

4-) Sadece gelen yada giden trafiği de kopyalayabiliriz. Bu işlem için rx (received traffic) ve tx (transmitted traffic) değerlerini kodların sonuna eklemeliyiz.

monitor session 4 source interface fast0/20 rx
monitor session 4 destination interface fast0/21
monitor session 5 source interface fast0/22 tx
monitor session 4 destination interface fast0/23

5-) Evet Cisco cihazlarda port mirroring işlemi bu kadar. Yaptığımız port mirroring işlemlerini switch üzerinden görüntülemek istediğimizde enable mod üzerinden aşağıdaki komutu uygulamamız yeterli olacaktır;

enable
show monitor session all

Bu komuttan sonra switch üzerindeki tüm port mirroring işlemleri gözükecektir.

6-) Son olarak port mirroring silmek için uygulamamız gereken komutu öğrenelim. Bunun için birinci adımda yaptığımız port mirroringi silelim;

no monitor session 1 source interface fast0/1
no monitor session 1 destination interface fast0/2

Cisco konularımıza devam edeceğiz. Bizi takip etmeye devam edin.

Cisco’da Farklı Vlanlara DHCP Sunucudan IP Dağıtma

Cisco cihazları kullandığımız network sistemlerinde, vlan yapısını kullandığımızda bu vlanlara dhcp sunucusunu tanıtmak için helper address tanımlaması yapmamız gerekmektedir. Yani farklı vlanlara dhcp sunucudan ip dağıtmak için router veya layer 3 switch üzerindeki vlanlara helper address girmemiz gerekmektedir. Bu yazıda bu işlemi daha iyi anlamak için örnek bir senaryo uygulayacağız. Bu senaryoda şuana kadar öğrendiğimiz komutları da tekrarlamış olacağız.

Örnek senaryomuzdaki yapımız şu şekildedir;

Yapımızda 3 adet vlan (vlan 10, vlan 20, vlan 50) bulunmaktadır. Dhcp sunucusu vlan 50’de olacaktır. Örnek yapımızı aşağıdaki görselden daha detaylı olarak inceleyebilirsiniz. Burada routerda tanımladığımız vlan 10 ve vlan 20 için helper address olarak dhcp sunucunun ip adresini göstereceğiz. Şimdi network cihazlarını yapılandırmak için uygulamamız gereken işlemleri öğrenelim;

1-) İlk olarak router cihazın switche bağlı olan gigabitEthernet0/0/0 portunu açıyoruz ve ip verilmeyecek şekilde yapılandırıyoruz. Bu port üzerinden vlanlar oluşturacağımız için bu şekilde işlem yapıyoruz;

enable
conf term
int gig0/0/0
no ip address
no shutdown
exit

2-) Bu port üzerinden ilk olarak vlan 50’yi oluşturuyoruz. Bu vlan dhcp sunucusu içindir.

int gig0/0/0.50
encapsulation dot1Q 50
ip address 192.168.50.1 255.255.255.0
exit

3-) Şimdi vlan 10 ve vlan 20’yi oluşturuyoruz ve bu vlanlarda helper address olarak dhcp sunucunun ip adresini gösteriyoruz;

int gig0/0/0.10
encapsulation dot1Q 10
ip address 192.168.1.1 255.255.255.0
ip helper-address 192.168.50.250
exit
int gig0/0/0.20
encapsulation dot1Q 20
ip address 10.0.0.1 255.0.0.0
ip helper-address 192.168.50.250
exit

4-) Evet router üzerinde yapmamız gereken ayarları tamamladık. Şimdi switch üzerindeki ayarlara geçiyoruz. Switch üzerinde ilk olarak routera bağlı olan portu (fasthEthernet0/1) trunk olarak yapılandırıyoruz;

enable
conf term
int fast0/1
no shutdown
switchport mode trunk
exit

5-) İkinci aşamada switch üzerinde network yapımızda bulunan vlanları oluşturuyoruz;

vlan 10
exit
vlan 20
exit
vlan 50
exit

6-) Şimdi switchin ikinci portunu (fasthEthernet0/2) vlan 50’ye dahil ediyoruz. Bu porta dhcp sunucusunu bağlamamız gerektiğini unutmamalıyız. Daha sonra üçüncü portu (fasthEthernet0/3) vlan 10’a dördüncü portu da (fasthEthernet0/4) vlan 20’ye dahil ediyoruz. Bu portlara iki adet bilgisayar bağlayacağız.

int fast0/2
no shutdown
switchport mode access
switchport access vlan 50
exit
int fast0/3
no shutdown
switchport mode access
switchport access vlan 10
exit
int fast0/4
no shutdown
switchport mode access
switchport access vlan 20
exit

7-) Şimdi dhcp sunucuyu switchte fasthEthernet0/2 portuna bağlıyoruz ve bu dhcp sunucuya aşağıdaki gibi sabit ip tanımlaması yapıyoruz;

Ip Address: 192.168.50.250
Subnet Mask: 255.255.255.0
Default Gateway: 192.168.50.1

😎 Daha sonra dhcp sunucuda vlan 10 networkü (192.168.1.0/24) için dağıtılacak olan ip adreslerini tanımlıyoruz.

Not: Biz Packet Tracer üzerinde yapılandırma yaptığımız için dhcp sunucu yapılandırma ekranı aşağıdaki gibi gözükmektedir.

Not2: Biz burada ip dağıtımının 192.168.1.25’den başlayacağını tanımladık.

9-) Vlan 20 networkü (10.0.0.0/8) içinde dağıtılacak olan ipleri tanımlayıp dhcp sunucu üzerinden yapmamız gereken işlemleri tamamlıyoruz.

Not: Biz burada ip dağıtımının 10.0.0.25’den başlayacağını tanımladık.

10-) Şimdi switchin fastEthernet0/3 (vlan 10) portuna bir bilgisayar bağlıyoruz ve bu bilgisayarı dhcp den ip alacak şekilde yapılandırıyoruz. Görselde de görüldüğü gibi bilgisayar 192.168.1.25 ip adresini aldı.

11-) Daha sonra switchin fastEthernet0/4 (vlan 20) portuna da bir bilgisayar bağlıyoruz ve bu bilgisayarı da aynı şekilde dhcp sunucudan ip alacak şekilde yapılandırıyoruz. Görselde de görüldüğü gibi bilgisayar 10.0.0.25 ip adresini aldı.

12-) Şimdi vlan 10’da bağlı olan bilgisayarın cmd komut satırını açıyoruz ve ipconfig komutunu uyguluyoruz. Görüldüğü gibi bu bilgisayar dhcp sunucudan 192.168.1.25 ip adresini almış. Şimdi karşı bilgisayara ping atmak için ping 10.0.0.25 komutunu uyguluyoruz. Görüldüğü gibi ping atma işlemi başarılı olarak gerçekleşti.

Cisco’da farklı vlanlara dhcp sunucudan ip dağıtma işlemi bu kadar. Cisco ile ilgili konularımıza devam edeceğiz. Bizi takip etmeye devam edin.

Onedrive Masaüstü Eşitleme

Onedrive, Microsoft’un bizlere sunduğu çevrimiçi dosya depolama ve paylaşma hizmetidir. Bu hizmeti kullanarak mobil cihazımız ve bilgisayarımız üzerinden dosyalarımıza çevrimiçi olarak erişebiliriz. Bilgisayarımızda Onedrive yazılımı kurulu ise yedekleme ayarı yaparak masaüstümüzü Onedrive ile eşitleyebiliriz. Bu şekilde bir işlem yaptığımızda bilgisayarımızın masaüstündeki dosyalara internet olan tüm cihazlardan erişebiliriz. Ayrıca bu işlem bilgisayarımızın bozulma olasılığına karşı dosyalarımızın yedeklenmesini sağlayacaktır. Şimdi bu işlemin nasıl yapıldığını öğrenelim;

Onedrive Masaüstü Nasıl Eşitlenir?

1-) Bu işlem için ilk olarak bilgisayarımızın sağ alt köşesinden Onedrive bulut simgesine tıklıyoruz. Açılan bölümden Yardım & Ayarlar yazan yere tıklıyoruz. Açılan menüden Ayarlar yazan yere tıklıyoruz.

2-) Gelen ekranda Yedekleme sekmesine tıklıyoruz. Açılan alt bölümden Yedeklemeyi Yönet yazan yere tıklıyoruz.

3-) Gelen ekranda sadece Masaüstü yazan bölümü seçili durumda bırakıyoruz ve Yedeklemeyi Başlat butonuna tıklıyoruz. Daha sonra gerekli onaylamaları yaparak işlemimizi tamamlıyoruz.

Evet Onedrive ile masaüstü eşitleme işlemi bu kadar kolay. Tekrar görüşmek üzere. Şimdilik hoşçakalın.

WHM SSH ile Sunucu Yedekleme

Web sunucular üzerine ücretli veya ücretsiz olarak kurabileceğimiz birçok hosting kontrol paneli bulunmaktadır. Bu paneller arasında Cpanel/WHM yer almaktadır. Kullanımının kolay olması ve birçok ihtiyacı başarılı bir şekilde karşılaması nedeniyle bu panelin dünya genelinde kullanım oranı çok yüksektir.

Cpanel’de birçok gelişmiş özellik bulunmaktadır. Yedeklemenin detaylı ve kolay bir şekilde yapılması bu özelliklerden bir tanesidir. Cpanel kurulu olan bir sunucu üzerinden uygulayacağımız bir komut ile sunucumuz üzerinde yer alan tüm web sitelerin yedeklerini alabilmemiz mümkündür. Şimdi bu işlem için uygulamamız gereken komutları öğrenelim;

1. Yöntem

Not: Göstereceğimiz iki yöntem ile de Whm sunucumuzdaki tüm web sitelerin full yedeklerini alabiliriz. İki yöntem içinde sunucumuza root kullanıcısı ile bağlantı yapmamız gerekmektedir. Aksi durumda yedekleme işlemi yapılmayacaktır.

/scripts/cpbackup -force

2. Yöntem

Bu yöntemde Cpanel’de yer alan kullanıcıları bir döngü içine alıp bu döngünün içinde yedekleme komutunu kullanarak sunucumuzdaki tüm hesapların yedeklemesini yapmış oluyoruz;

for i in $(ls /var/cpanel/users); do /scripts/pkgacct $i;done

Not: Yedek dosyasını kontrol etmek için ls komutunu kullanabilirsiniz.

Bu komutların çalışması bitene kadar ssh ekranından çıkış yapılmamalıdır. Tekrar görüşmek üzere. Şimdilik hoşçakalın.

Modemi Fabrika Ayarlarına Döndürme

Güvenlik için modem arayüzüne bir şifre tanımlamamız önemlidir. Bu şifreyi unuttuğumuzda modem üzerinden herhangi bir ayar yapamayız (wi-fi şifre değiştirme, port açma vb). Bu durumda modemi fabrika ayarlarına çevirmekten başka çaremiz yoktur.

Modemleri fabrika ayarlarına çevirmek çok kolay bir işlemdir. Genel olarak tüm modemlerde bu işlem aynı şekilde yapılmaktadır.

Modem Fabrika Ayarına Nasıl Çevrilir?

Bu işlem için ilk olarak modemimizin elektrik bağlantısını yapıyoruz. Genellikle modemlerin arkasında ufak bir delik olmaktadır. Bu deliğin içinde modem resetleme düğmesi bulunmaktadır. Ataç gibi bir cisimle bu deliğin içindeki düğmeye bastırdığımızda (bu düğmeye uzun süre basmamız gerekebilir) modem kapanıp açılacaktır. Bu işlemlerden sonra modem fabrikaya ayarlarına çevrilmiş olacaktır. Artık modemin marka ve modeline göre varsayılan olarak tanımlanan kullanıcı adı ve şifre ile arayüze ulaşabiliriz.

Modemi fabrika ayarlarına çevirme işlemi bu kadar. Tekrar görüşmek üzere. Şimdilik hoşçakalın.

Modem’in IP Adresini Öğrenme

Modem IP Öğrenme

Bazı durumlarda modeme bağlantı yapıp ayar yapmamız gerekebilir. Özellikle wi-fi şifre tanımlama veya şifre değiştirme gibi ayarlar için modeme bağlantı yapma ihtiyacı duyabiliriz. Bu bağlantıyı sağlamak için modem ip adresini bilmemiz gerekmektedir. Modem ip adresini unuttuysak cmd komut ekranını kullanarak ip adresini öğrenebiliriz.

Modem ip adresini öğrenmeden önce modem ile bilgisayar arasında kablo ile bağlantı yapmamız gerekmektedir. Bunun yanında modeme kablosuz bağlantı yapmamızda yeterli olacaktır. Bu gereksinimleri karşıladıktan sonra modem ip adresini öğrenmek için uygulamamız gereken adımlar şu şekildedir;

1-) İlk olarak Windows bilgisayarımızdan Windows + R tuşlarına birlikte basıyoruz. Açılan ekrana cmd yazıp Tamam butonuna tıklıyoruz.

2-) Gelen ekranda ipconfig komutunu yazıp enter tuşuna basıyoruz.

3-) Gelen çıktıda Default Gateway ve Varsayılan Ağ Geçidi yazan yerin karşısındaki değer modemin ip adresidir.

Modem ip adresi öğrenme işlemi bu kadar kolay. Bu işlem ile ilgili sorunlarınızı yorum bölümünden bize iletebilirsiniz.