Cisco’da Farklı Vlanlara DHCP Sunucudan IP Dağıtma

Cisco cihazları kullandığımız network sistemlerinde, vlan yapısını kullandığımızda bu vlanlara dhcp sunucusunu tanıtmak için helper address tanımlaması yapmamız gerekmektedir. Yani farklı vlanlara dhcp sunucudan ip dağıtmak için router veya layer 3 switch üzerindeki vlanlara helper address girmemiz gerekmektedir. Bu yazıda bu işlemi daha iyi anlamak için örnek bir senaryo uygulayacağız. Bu senaryoda şuana kadar öğrendiğimiz komutları da tekrarlamış olacağız.

Örnek senaryomuzdaki yapımız şu şekildedir;

Yapımızda 3 adet vlan (vlan 10, vlan 20, vlan 50) bulunmaktadır. Dhcp sunucusu vlan 50’de olacaktır. Örnek yapımızı aşağıdaki görselden daha detaylı olarak inceleyebilirsiniz. Burada routerda tanımladığımız vlan 10 ve vlan 20 için helper address olarak dhcp sunucunun ip adresini göstereceğiz. Şimdi network cihazlarını yapılandırmak için uygulamamız gereken işlemleri öğrenelim;

1-) İlk olarak router cihazın switche bağlı olan gigabitEthernet0/0/0 portunu açıyoruz ve ip verilmeyecek şekilde yapılandırıyoruz. Bu port üzerinden vlanlar oluşturacağımız için bu şekilde işlem yapıyoruz;

enable
conf term
int gig0/0/0
no ip address
no shutdown
exit

2-) Bu port üzerinden ilk olarak vlan 50’yi oluşturuyoruz. Bu vlan dhcp sunucusu içindir.

int gig0/0/0.50
encapsulation dot1Q 50
ip address 192.168.50.1 255.255.255.0
exit

3-) Şimdi vlan 10 ve vlan 20’yi oluşturuyoruz ve bu vlanlarda helper address olarak dhcp sunucunun ip adresini gösteriyoruz;

int gig0/0/0.10
encapsulation dot1Q 10
ip address 192.168.1.1 255.255.255.0
ip helper-address 192.168.50.250
exit
int gig0/0/0.20
encapsulation dot1Q 20
ip address 10.0.0.1 255.0.0.0
ip helper-address 192.168.50.250
exit

4-) Evet router üzerinde yapmamız gereken ayarları tamamladık. Şimdi switch üzerindeki ayarlara geçiyoruz. Switch üzerinde ilk olarak routera bağlı olan portu (fasthEthernet0/1) trunk olarak yapılandırıyoruz;

enable
conf term
int fast0/1
no shutdown
switchport mode trunk
exit

5-) İkinci aşamada switch üzerinde network yapımızda bulunan vlanları oluşturuyoruz;

vlan 10
exit
vlan 20
exit
vlan 50
exit

6-) Şimdi switchin ikinci portunu (fasthEthernet0/2) vlan 50’ye dahil ediyoruz. Bu porta dhcp sunucusunu bağlamamız gerektiğini unutmamalıyız. Daha sonra üçüncü portu (fasthEthernet0/3) vlan 10’a dördüncü portu da (fasthEthernet0/4) vlan 20’ye dahil ediyoruz. Bu portlara iki adet bilgisayar bağlayacağız.

int fast0/2
no shutdown
switchport mode access
switchport access vlan 50
exit
int fast0/3
no shutdown
switchport mode access
switchport access vlan 10
exit
int fast0/4
no shutdown
switchport mode access
switchport access vlan 20
exit

7-) Şimdi dhcp sunucuyu switchte fasthEthernet0/2 portuna bağlıyoruz ve bu dhcp sunucuya aşağıdaki gibi sabit ip tanımlaması yapıyoruz;

Ip Address: 192.168.50.250
Subnet Mask: 255.255.255.0
Default Gateway: 192.168.50.1

😎 Daha sonra dhcp sunucuda vlan 10 networkü (192.168.1.0/24) için dağıtılacak olan ip adreslerini tanımlıyoruz.

Not: Biz Packet Tracer üzerinde yapılandırma yaptığımız için dhcp sunucu yapılandırma ekranı aşağıdaki gibi gözükmektedir.

Not2: Biz burada ip dağıtımının 192.168.1.25’den başlayacağını tanımladık.

9-) Vlan 20 networkü (10.0.0.0/8) içinde dağıtılacak olan ipleri tanımlayıp dhcp sunucu üzerinden yapmamız gereken işlemleri tamamlıyoruz.

Not: Biz burada ip dağıtımının 10.0.0.25’den başlayacağını tanımladık.

10-) Şimdi switchin fastEthernet0/3 (vlan 10) portuna bir bilgisayar bağlıyoruz ve bu bilgisayarı dhcp den ip alacak şekilde yapılandırıyoruz. Görselde de görüldüğü gibi bilgisayar 192.168.1.25 ip adresini aldı.

11-) Daha sonra switchin fastEthernet0/4 (vlan 20) portuna da bir bilgisayar bağlıyoruz ve bu bilgisayarı da aynı şekilde dhcp sunucudan ip alacak şekilde yapılandırıyoruz. Görselde de görüldüğü gibi bilgisayar 10.0.0.25 ip adresini aldı.

12-) Şimdi vlan 10’da bağlı olan bilgisayarın cmd komut satırını açıyoruz ve ipconfig komutunu uyguluyoruz. Görüldüğü gibi bu bilgisayar dhcp sunucudan 192.168.1.25 ip adresini almış. Şimdi karşı bilgisayara ping atmak için ping 10.0.0.25 komutunu uyguluyoruz. Görüldüğü gibi ping atma işlemi başarılı olarak gerçekleşti.

Cisco’da farklı vlanlara dhcp sunucudan ip dağıtma işlemi bu kadar. Cisco ile ilgili konularımıza devam edeceğiz. Bizi takip etmeye devam edin.

Ubuntu Server 20.04 LTS Kurulumu

Ubuntu, Linux alt yapısı ile geliştirilmiş, ücretsiz bir işletim sistemidir. Bu işletim sistemi kişisel bilgisayarların yanı sıra sunucularda ve akıllı telefonlarda kullanılması için çalışmalar yapılmıştır. Bu yazıda Ubuntu’nun sunucu platformları için geliştirilmiş olan Ubuntu Server 20.04 LTS sürümünün kurulumunu detaylı bir şekilde anlatacağız.

Ubuntu Server kurulumu için iso dosyasını internet üzerinden indirdikten sonra bu dosyayı bir usb bellekten veya dvd’den boot olacak şekilde yazdırmamız gerekmektedir. Sanal makineye kurulum yapmak için sadece iso dosyasını elde etmemiz yeterli olacaktır. Bilgisayarımızı veya sunucumuzu Ubuntu server medyasından boot yaptıktan sonra bu işletim sisteminin kurulumu için aşağıdaki adımları uygulamamız yeterli olacaktır;

1-) Ubuntu Server kurulum aşamasında karşımıza gelen ilk ekrandan işletim sisteminin dilini seçmemiz gerekmektedir. Burada English yazan yerin üstüne gelip enter yapıyoruz.

2-) Gelen ekranda klavyemizin dilini seçmemiz gerekmektedir. Burada Layout yazan yerin üstüne gelip enter tuşuna basıyoruz.

3-) Gelen ekradan Turkish yazan yeri seçip enter tuşuna basarak klavyemizi Türkçe olarak tanımlıyoruz.

4-) Görüldüğü gibi Turkish seçili duruma geldi. Done yazan yerin üstüne gelip enter yaparak kuruluma devam ediyoruz.

5-) Ağ kartı ip yapılandırma ekranı karşımıza gelecektir. Bu bölüm varsayılan olarak dhcp sunucudan ip alacak şekilde ayarlıdır. Biz sabit ip tanımlaması yapmak için ağ kartı isminin üstüne gelip enter tuşuna basıyoruz.

6-) Açılan alt bölümden Edit IPv4 yazan yere tıklıyoruz.

7-) Gelen ekranda IPv4 Method yazan bölümden Manuel yazan yeri seçiyoruz.

😎 Gelen ekranda ip ayarlarını aşağıdaki görseldeki gibi yapımıza uygun olarak dolduruyoruz;

Subnet: Bu bölüme CIDR olarak tanımlama yapmamız gerekmektedir. Biz bu cihazı networkte 10.0.2.0/24 ağına alacağımız için subneti bu şekilde tanımladık. Buradaki 10.0.2.0 değeri ağ adresimizi /24 değeri subneti belirtmektedir 255.255.255.0’la aynı anlama gelmektedir.
Address: Bu bölüme sunucuya vereceğimiz sabit ip değerini giriyoruz.
Gateway: Ortamımızda modem veya router bulunuyorsa bu cihazın ip adresini buraya giriyoruz.
Name Server: Bu bölüme dns sunucu adreslerini giriyoruz. Biz örneğimizde Google dns sunucu adresini girdik.

Gerekli tanımlamaları yaptıktan sonra Save butonuna tıklıyoruz.

9-) Ortamımızda Proxy varsa gelen ekranda proxy adresini girebiliriz. Biz bu bölüme bir değer girmeden Done diyerek geçiyoruz.

10-) Configure ubuntu archive mirror ekranında bir değişiklik yapmadan Done diyerek geçiyoruz.

11-) Kurulum için disklerimizi yapılandırabileceğimiz bölüm karşımıza gelecektir. Bu bölümü Use an entire disk yazan yeri seçip devam edersek disk yapısı lvm olarak sistem tarafından otomatik olarak yapılandırılacaktır. Biz detaylı bir kurulum yapacağımız için bu bölümü Custom storage layout yazan yeri seçerek ve Done yaparak kuruluma devam ediyoruz.

12-) Gelen ekranda ilk olarak lvm yapısında volume grup oluşturmak için Create volume group yazan yerin üstüne geliyoruz ve enter yapıyoruz.

13-) Gelen ekranda ilk olarak Name bölümüne volume grup için bir isim veriyoruz. Varsayılan olarak bırakabiliriz. Daha sonra Device bölümünden volume grup içine eklemek istediğimiz diski veya diskleri seçiyoruz. Bizim yapımızda 33 gb lık bir tane disk olduğu için sadece bu diski seçtik. Daha sonra Create yazan bölümün üstüne gelip enter yaparak işlemi tamamlıyoruz.

14-) Gelen ekranda oluşturduğumuz volume grubumuzu görüyoruz ve bu ekrandan Back diyerek geri dönüyoruz.

15-) Done diyerek disk yapılandırma aşamasına devam ediyoruz.

16-) Gelen ekradan /boot (işletim sisteminin boot olması için gerekli dosyalar bu bölümde olacaktır) ve / (sistem ile ilgili tüm dosyalar bu alanda barınacaktır) olarak iki adet logical volume grubun otomatik oluştuğunu üst tarafta görüyoruz. Bu bölümlerin boyutları sistem tarafından otomatik olarak oluşturulacaktır. İstersek bu boyutları arttırıp azaltabiliriz. Lvm yapısının güzelliği burada ortaya çıkıyoruz. Bu sayfada Free space bölümünden yaklaşık olarak 12 gb lık alanın boşta olduğunu görüyoruz. Biz örnek olması açısından /var dizini için logical volume oluşturacağız ve bu boştaki 12 gb lık alanı bu bölüme atayacağız. Bu işlem için Used Device bölümünden daha önce oluşturmuş olduğumuz Volume group un üstünde gelip enter tuşuna basıyoruz.

17-) Açılan alt bölümden Create Logical Volume yazan yerin üstünde enter tuşuna basıyoruz.

18-) Açılan ekranda Name bölümüne logical volume için bir isim giriyoruz. Size bölümüne oluşturduğumuz logical volume nin boyutunu giriyoruz. Biz 12 gb ın tamamını kullanacağımız için bir değer girmiyoruz (boş bırakmak tüm alanı kullan anlamına gelmektedir). Burada Format bölümünü ext4 olarak bırakıyoruz. Bu Linux’un desteklediği disk formatıdır. Mount bölümünden /var yazan yeri seçiyoruz ve Create yapıp logical volume oluşturma işlemini tamamlıyoruz.

19-) Eklediğimiz logical volume bölümü gözükmektedir. Kurulum işlemine devam etmek için Done yapıyoruz.

20-) Karşımıza bir uyarı mesajı gelecektir. Bu uyarı mesajında disklerin formatlanacağı ve içindeki verilen silineceği uyarısı yapılmaktadır. Bu bölümü Continue yaparak geçiyoruz ve işlemi onaylıyoruz.

21-) Kullanıcı ekleme bölümü karşımıza gelecektir. Bu bölümde gerekli alanları dolduruyoruz ve Ubuntu’da kurulum sonrası login olacağımız bir hesap oluşturuyoruz.

22-) Eğer sisteme ssh ile uzaktan bağlantı yapacaksak gelen ekranda Install OpenSSH Server yazan yeri seçiyoruz. Biz bu alanı seçmeden Done yaparak kuruluma devam ediyoruz.

23-) Kurmak istediğimiz servislerin listesinin olduğu bir ekran karşımıza gelecektir. Bu bölümden kurmak istediğimiz servisleri seçip devam edebiliriz. Bu servisleri istediğimiz zaman kurabiliriz. Bura herhangi bir seçim yapmadan Done diyerek devam ediyoruz.

24-) Ubuntu Server kurulumu başlayacaktır.

25-) Kurulum tamamlandığında Reboot Now aktif olacaktır. Bu bölümün üstüne gelip enter yaptığımızda sistemimiz yeniden başlayacaktır ve işletim sistemi kurulu olarak karşımıza gelecektir.

Ubuntu Server kurulum işlemi bu şekildedir. Linux ile ilgili konularımıza devam edeceğiz. Bizi takip etmeye devam edin.

Linux Kullanıcıya Root Yetkisi Verme

Linux işletim sistemlerinde kullanıcıya root yetkisi vermek için /etc dizini içinde yer alan sudoers dosyasına root yetkisi vermek istediğimiz kullanıcıyı tanımlamamız gerekmektedir. Şimdi bu işlem için uygulamamız gereken adımları detaylı olarak öğrenelim;

1-) İlk olarak sistemimizde deneme isimli kullanıcı oluşturmak için aşağıdaki komutu uyguluyoruz. Bu kullanıcıya root yetkisi vereceğiz;

sudo adduser deneme

Bu komuttan sonra bizden root kullanıcımızın şifresi istenecektir. Kullanıcı ekleme işlemi root yetkisi gerektiğinden dolayı gerekli şifreyi girmeliyiz. Root şifremizi girdikten sonra yeni kullanıcının bilgilerini girmemiz istenecektir. Bu bilgilerden önemli olanları şunlardır

New password: Deneme kullanıcısı için tanımlamak istediğimiz parolayı giriyoruz.
Retype password: Parolanın tekrarını giriyoruz.
Full name: Oluşturduğumuz deneme isimli kullanıcının tam ismini giriyoruz.
Diğer alanları hiçbir değer girmeden enter yaparak geçebiliriz. En son aşamada bizden yeni eklediğimiz kullanıcının bilgilerinin doğruluğunu onaylamamız istenecektir. Y tuşuna basıp enter yaptığımızda deneme isimli kullanıcı eklenmiş olacaktır.

2-) Yeni kullanıcıyı ekledikten sonra bu kullanıcıya root yetkisi vermek için aşağıdaki komutu uygulayarak etc dizini içinde yer alan sudoers dosyasını açıyoruz;

sudo nano /etc/sudoers

3-) Açılan dosyada aşağıdaki bölümü buluyoruz. Bu bölümde root kullanıcısının tanımının altına deneme kullanıcısı için root yetkisi tanımını giriyoruz;

#User privilege specification
root ALL=(ALL:ALL) ALL
deneme ALL=(ALL:ALL) ALL

Gerekli tanımlamayı yaptıktan sonra dosyayı kaydetmek için ilk olarak CTRL + X tuşlarına birlikte basıp daha sonra Y tuşuna basıp enter yapıyoruz.

Bu işlemden sonra kullanıcıya root yetkisi vermiş olacağız.

Cisco Router VLAN Konfigürasyonu

Network yapılarında güvenlik ve performans için vlanların (sanal ağlar) kullanılması
önemli olmaktadır. Vlan yapısının kullanıldığı sistemlerde vlanlar arası haberleşme sağlanması için router veya layer 3 switche ihtiyaç bulunmaktadır.

Bu yazıda Cisco Router üzerinden vlan yapısının nasıl ayarlanacağını basit bir şekilde anlatacağız. Örnek senaryomuzda sistemimizde bir adet router, bir adet layer 2 switch bulunmaktadır. Bu cihazlarda iki adet vlan (vlan 10, vlan 20) olacak ve bu vlanlar router ve switch üzerinde oluşturulup, iki farklı vlanda olan bilgisayarın haberleşmesi sağlanacaktır. Aşağıdaki görselden sistemimizin yapısını daha iyi anlayabilirsiniz.

Vlan 10= 192.168.1.0/24
Vlan 20= 10.0.0.0/8

1-) Yapılandırmamız için ilk olarak router üzerinden aşağıdaki komutları uyguluyoruz;

enable
conf term
int gig0/0/0
no shutdown
no ip address
int gig0/0/0.10
encapsulation dot1Q 10
ip address 192.168.1.1 255.255.255.0
exit

Burada ilk olarak routerda switche bağlanan portu (gigibitEthernet0/0/0) açtık ve bu porta ip verilmeyeceğini belirtmiş olduk. Bu port üzerinden vlanlar oluşturarak ip adresi tanımlaması yapacağız. Bu işlemi ilk olarak vlan 10 oluşturmak için int gig0/0/0.10 komutunu uygulayarak yaptık ve daha sonra ip adresini tanımladık. Ayrıca burada encapsulation dot1Q 10 komutunu uygulayarak vlan 10’u etiketledik.

Not: Dot1Q (802.1Q) IEEE tarafından geliştirilmiş olan vlan kapsülleme (encapsulation) standartıdır. Network yapılarında vlan kimliğinin ne olduğunu belirler ve port üzerinden geçecek olan vlan bilgilerini etiketlemeye yarar. Bu şekilde farklı vlanların haberleşmesi sağlanır.

2-) Şimdi routerda vlan 20 oluşturmak ve bu vlanı etiketlemek için gerekli komutları yazalım;

int gig0/0/0.20
encapsulation dot1Q 10
ip address 10.0.0.1 255.0.0.0
exit

3-) Routerdaki işlemlerimizi tamamladık. Switchte yapacağımız işlemlere geçiyoruz. İlk olarak switchte routera bağlı olan portu açıp bu portu trunk olarak yapılandırıyoruz. Farklı vlanların bu port üzerinden taşınması için bu işlemi yapıyoruz. Bu işlemler için uygulamamız gereken komutlar şu şekildedir;

enable
conf term
int fast0/1
no shutdown
switchport mode trunk
exit

4-) Switch üzerinde vlanları (vlan 10,20) oluşturmak için aşağıdaki komutları uyguluyoruz;

vlan 10
name personel
vlan 20 
name konuk
exit

5-) Daha sonra switchte 2 numaralı portu (fastethErnet0/2) vlan 10’a dahil edip erişim portu yapıyoruz. Aynı işlemi 3 numaralı portu (fastethErnet0/3) vlan 20’ye dahil ederek yapıyoruz. Bu işlem için uygulamamız gereken komutlar şu şkeildedir;

int fast0/2
switchport mode access 
switchport access vlan 10
no shutdown
exit
int fast0/3
switchport mode access 
switchport access vlan 20
no shutdown

6-) Şimdi switchte fastEthernet0/2 portuna bir bilgisayar bağlıyoruz ve bu bilgisayara 192.168.1.0/24 networkünden bir ip adresi atıyoruz. Bu switch portu vlan 10’a dahil olduğu için bu şekilde tanımlama yaptık. Biz görseldeki gibi ip tanımlaması yaptık;

7-) Aynı şekilde switchte fastEthernet0/3 portuna da bir bilgisayar bağlıyoruz. Bu bilgisayarın ip adresini 10.0.0.0/8 networkünden veriyoruz. Bu switch portu vlan 20’ye dahil olduğu için bu şekilde tanımlama yaptık. Biz görseldeki gibi ip tanımlaması yaptık;

😎 Evet şimdi fastEthernet0/2 portuna bağlı olan bilgisayarın cmd komut ekranını açıyoruz ve ipconfig komutu uyguluyoruz. Görselde de görüldüğü gibi bilgisayarın ip adresi 192.168.1.2’dir (vlan 10). Bu bilgisayardan diğer vlandaki bilgisayara ping atmak için komut ekranına ping 10.0.0.2 komutunu uyguluyoruz. Görselde de gözüktüğü gibi ping atma işlemi başarılı olarak gerçekleşti. Diğer bilgisayardan da bu bilgisayara ping atabiliriz. Farklı vlanlardaki bilgisayarlar başarılı olarak haberleşebiliyor.

Cisco ile ilgili konularımıza devam edeceğiz. Bizi takip etmeye devam edin.

Centos 8 Kurulumu

Linux tabanlı işletim sistemlerinden bir tanesi olan Centos 8’in kurulumunu bu yazıda detaylı bir şekilde anlatacağız. Kurulum için internetten indireceğimiz Centos 8 iso dosyasına ve bu dosyayı boot olacak şekilde yazdıracağımız bir aygıta (usb bellek, dvd) ihtiyacımız bulunmaktadır. Eğer sanal işletim sistemi olarak kurulum yapacaksak sadece iso dosyası işimizi görecektir. Bu ihtiyaçları karşıladıktan sonra iso dosyasını boot olacak şekilde aygıtlarımızdan bir tanesine (usb bellek veya dvd) yazdırdıktan sonra bilgisayarımızı bu aygıttan boot olacak şekilde ayarlamamız Centos 8 işletim sisteminin kurulumunu başlatacaktır. Daha önce Windows işletim sistemi kurulumu yapanlar Centos 8 kurulum aşamasına gelene kadar (boot olana kadar) sıkıntı yaşamayacaklardır. Buraya kadar her şey tamamsa kurulum işlemlerine geçebiliriz. Şimdi Centos 8 kurulum adımlarını öğrenelim;

1-) Centos 8 kurulum aşamasında karşımıza gelen ilk ekrandan Install Centos Linux 8 bölümünün üstüne gelip enter tuşuna basıyoruz.

2-) Gelen ekranda dil ayarlarımızı belirliyoruz. Eğer cihazımızı sunucu olarak kullanacaksak bu bölümü İngilizce olarak bırakmalıyız. Kurulum yapacağımız servislerin (bind, apache) ve yazılımların düzgün olarak çalışması için bu şekilde tanımlama yapmamız önemlidir. Gerekli seçimi yaptıktan sonra Continue butonuna tıklayıp kuruluma devam ediyoruz.

3-) Karşımıza Installation Summary ekranı gelecektir. Centos 8 kurulum ile ilgili ayarların tamamını bu bölüm üzerinden yapacağız. Yani bu bölüme çok sık geleceğiz. Sırasıyla gitmek için ilk olarak Keyboard bölümüne tıklıyoruz.

4-) Karşımıza gelen ekrandan klavye eklemek için + butonuna tıklıyoruz.

5-) Gelen ekranda Turkish yazan yeri seçip Add butonuna tıklıyoruz.

6-) Görselde de görüldüğü gibi Türkçe klavyemiz başarılı olarak eklendi. Kurulum ayalarının yapıldığı ekrana geri dönmek için Done butonuna tıklıyoruz.

7-) Tarih ve saat ayarlarımızı yapmak için Time & Date yazan bölüme tıklıyoruz.

😎 Gelen ekranda kısa yoldan haritadan bölgemizi seçerek tarih ve saat ayarlarımıza yapabiliriz. Gerekli seçimi yaptıktan sonra Done butonuna tıklıyoruz.

9-) Kurulum ekranında User Settings bölümünün altından Root Password yazan yere tıklıyoruz.

10-) Gelen ekranda root kullanıcısı için bir parola tanımlaması yapıyoruz. Bu kullanıcı sistem üzerinde tam yetkiye sahip olduğundan dolayı kompleks bir parola tanımlanmalıdır. Gerekli tanımlamayı yaptıktan sonra Done butonuna tıklıyoruz.

11-) Installation Source bölümüne tıklayarak kurulum ayarlarına devam ediyoruz.

12-) Bu bölümde Centos 8 iso dosyasının doğruluğunu kontrol edebiliriz. Yani bu iso dosyasında zararlı bir yazılımın olup olmadığını bu bölüm üzerinden kontrolünü sağlayabiliriz. Bu işlem için Verify butonuna tıklamamız yeterlidir. Bu işlemden sonra sorgulama işime yaklaşık 2-3 dakika sürecektir.

13-) Aşağıdaki görseldeki gibi bir çıktı aldıysak işletim sistemi kurulumu iso dosyası temiz demektir. Centos 8’in bize sunduğu güzel bir özelliktir. Bu bölümü Done butonuna basarak kapatıyoruz.

14-) Gelen ekranı Done butonuna basarak geçiyoruz.

15-) Software Selection bölümüne tıklayarak işlemlerimize devam ediyoruz.

16-) Gelen ekranda işletim sisteminin kurulum tipini ve kuracağımız servisleri seçebiliriz. Biz grafiksel arayüz olacak şekilde server rolünde kurulum yapacağımız için Server with GUI yazan yeri seçiyoruz ve Done butonuna tıklıyoruz. Eğer grafiksel arayüz olmadan sadece komut satırı olarak yönetebileceğimiz bir server işletim sistemi olarak kurulum yapacaksak (performans için tavsiye edilir) Server bölümünü seçebiliriz. Ekranın sağ tarafından herhangi bir servis seçmiyoruz. Bu servislerinden ihtiyacımız olanları istediğimiz zaman daha sonra kurabiliriz.

17-) Ip ayarlarımızı kurulum aşamasında yapmak için Network & Host Name yazan yere tıklıyoruz.

18-) Eğer kurulum yapacağımız sunucu dhcp den otomatik olarak ip alacaksa bu bölümden ağ kartını ON olarak ayarlamamız (OFF yazan bölüme tıkladığımızda ON olacaktır) yeterli olacaktır. Yani ağ kartını aktif yaptığımızda cihazımız dhcp den ip alacak şekilde yapılandırılacaktır. Eğer sabit ip vereceksek ağ kartımızı aktif (ON) yaptıktan sonra aynı sayfadan Configure butonuna tıklayarak gerekli ayarları yapmalıyız. Siz yapınıza göre gerekli işlemi yapmalısınız. Biz sabit ip olacak şekilde sunucumuzu yapılandıracağız.

Not: Bu ayarların tamamını işletim sistemi kurulumu sonrası değişitirebiliriz.

19-) Gelen ekranda ilk olarak IPv4 Settings yazan sekmeye tıklıyoruz. Daha sonra Method bölümünden Manuel yazan bölümü seçiyoruz ve Add butonuna tıklıyoruz. Daha sonra Address bölümüne gerekli ip değerini yazıyoruz. İstediğimize göre DNS Server bölüme dns adresleri de girebiliriz. Gerekli tanımlamaları yaptıktan sonra Save butonuna tıklayarak yaptığımız değişiklikleri kaydediyoruz.

20-) Network ayarları sayfasından Host Name bölümüne sunucumuz için bir isim de verebiliriz. Gerekli tanımlamayı yaptıktan sonra Done butonuna tıklıyoruz.

21-) Sırada disk ile ilgili ayarların yapıldığı en önemli bölüm var. Bu işlem için Installation Destination yazan bölüme tıklıyoruz.

22-) Gelen ekranda Storage Configuration bölümünde Automatic yazan yeri seçersek disk ayarlarımız sistem tarafından otomatik olarak yapılandırılacaktır. Biz detaylı bir kurulum yapmak için Custom yazan yeri seçiyoruz ve üst taraftan Done butonuna tıklıyoruz.

23-) Gelen ekranda disk yapısı olarak LVM seçili gelecektir. Lvm yapıs,ı kurulumdan sonra disklerimizi detaylı bir şekilde yönetmemize olanak sağlayacaktır. Lvm yapısında disk bölümleri oluşturmak için + butonuna tıklıyoruz.

24-) Gelen ekranda ilk olarak Mount Point bölümünden /boot yazan yeri seçiyoruz ve Desired Capacity bölümüne 500 değerini veriyoruz. Burada mb cinsinden bir değer vermemiz gerekmektedir. Boot bölümü için 500 mb’lık değer yeterli olacaktır. Bu bölüm işletim sisteminin boot olması için gerekli olan dosyaları bünyesinde barındıracaktır. Gerekli değerleri girdikten sonra Add mount point butonuna tıklıyoruz.

25-) Görüldüğü gibi boot bölümü başarılı olarak oluşturuldu. Tekrar + butonuna tıklıyoruz.

26-) Bu defa Mount Point bölümünden swap yazan yeri seçiyoruz. Swap, bilgisayarımızdaki ram belleğin tamamının kullanılması durumunda ram bellek görevini harddiskin üstlenmesi işlemidir. Burada hard diskimizin ne kadarlık kısmının ram görevini (swap) yerine getireceğini belirteceğiz. Biz burada swap alanı için 2gb lık bir değer girdik. Siz yapınıza göre gerekli değeri vermelisiniz. Gerekli yerleri doldurduktan sonra Add mount point butonuna tıklıyoruz.

27-) Swap bölümü de başarılı olarak oluşturuldu. Bu bölümden tekrar + butonuna tıklıyoruz.

28-) Mount Point bölümünden bu sefer / yazan yeri seçiyoruz ve Desired Capacity yazan yeri boş bırakıp Add mount point butonuna tıklıyoruz. Bu işlem ile diskimizde kalan tüm bölümü sisteme (kullanıcı dizinleri, sistem dosyaları) ayırmış olduk ve disk bölümleme işlemini tamamladık.

29-) Disk ayarlarını tamamladıktan sonra Done butonuna tıklıyoruz.

30-) Yaptığımız disk ayarlarının özetinin yazdığı bir bölüm karşımıza gelecektir. Gerekli kontrolleri yaptıktan sonra yaptığımız değişiklikleri onaylamak için Accept Changes yazan butona tıklıyoruz.

31-) Evet kurulum ayarlarını tamamladık. Yaptığımız ayarlar doğrultusunda kurulumu başlatmak için Begin Installation butonuna tıklıyoruz.

32-) Centos 8 kurulumu başlayacaktır.

33-) Kurulum tamamlandığında Reboot System butonu aktif olacaktır. Bu butona tıkladığımızda sistem yeniden başlayacaktır.

34-) Sistem açıldıktan sonra INITIAL SETUP bölümü karşımıza gelecektir. Bu bölümden ilk olarak lisansı onaylamak için License Information yazan yere tıklıyoruz.

35-) Gelen ekranda I accept the license agreement yazan yeri seçip Done butonuna tıklıyoruz.

36-) Son olarak root kullanıcısı dışında bir kullanıcı oluşturmak için User Creation yazan yere tıklıyoruz. Bu bölüm zorunlu değildir.

37-) Açılan bölümde yeni oluşturacağımız kullanıcının bilgilerini istediğimiz doğrultuda giriyoruz ve Done butonuna tıklıyoruz.

38-) Kurulumu bitirmek için Finish Configuration butonuna tıklıyoruz.

Evet bu işlemlerden sonra Centos 8 kurulumu tamamlanacaktır. Tekrar görüşmek üzere. Şimdilik hoşçakalın.

Cisco Switch Vlan IP Verme

Cisco switchlerde oluşturduğumuz vlanlara ip ataması yapabiliriz. Bu işlemi yapmak için uygulamamız gereken komutlar şu şekildedir;

1-) İlk olarak aşağıdaki komutları uygulayarak switchimizde bir vlan oluşturuyoruz;

enable
conf term
vlan 10
exit

Bu komutlar ile switchimizde vlan 10 isimli bir vlan oluşturmuş olduk.

2-) Şimdi oluşturduğumuz bu vlana ip adresi verelim. Bu işlem için uygulamamız gereken komutlar şu şekildedir;

interface vlan 10
ip address 192.168.1.250 255.255.255.0
exit
exit

Bu komutlar ile vlan 10’a 192.168.1.250 ip adresini vermiş olduk.

3-) Şimdi ip adresin kontrolünü yapalım. Bu işlem için kullanmamız gereken komut şu şekildedir;

show ip interface brief

Evet görüldüğü gibi vlan 10’da verdiğimiz ip adresi gözükmektedir. Cisco konularımıza devam edeceğiz. Bizi takip etmeye devam edin.