Yazar arşivleri: onur

Cisco Konsol Şifresi Verme

Cisco cihazlar kullanılan network ortamlarında cihazlara fiziksek olarak erişebilecek durumda olanların konsol kablosu ile cihazlara şifresiz olarak erişmeleri istenmeyen bir durumdur. Bu nedenden dolayı güvenlik için tüm cihazlarda consol şifresi tanımlanması yapılmalıdır.

Cisco cihazlarda konsol şifre tanımlama işlemi birkaç adımdan oluşmaktadır. Şimdi bu adımları öğrenelim;

1-) İlk olarak konsol şifresi vermek istediğimiz cihaza konsol kablosu ile bağlantı yapıyoruz. Bu işlem için Hyper terminal veya Putty gibi programlardan bir tanesini kullanabiliriz. Yeni veya sıfırlanmış bir cihazda bu şekilde direkt olarak bağlantı yapabiliriz. Cihaza ulaştıktan sonra aşağıdaki komutları sırasıyla uyguluyoruz;

enable
conf term
line console 0
password 12345
login
exit
exit
write memory

Evet bu şekilde konsol şifresini 12345 olarak verdik. Tabi siz bu şekilde kolay bir şifre tanımlamayın.

2-) İşlemimizi bu aşamada bıraktığımızda bir güvenlik açığı oluşacaktır. Enable mod üzerinden cihaz konfigürasyonunu görüntülediğimizde konsol şifresi açık bir şekilde gözükecektir. Bu işlem için enable mod üzerinden aşağıdaki komutu uyguluyoruz ve şifremizin açık bir şekilde gözüktüğünü görüyoruz;

show startup-config

Evet görüntüde de gözüktüğü gibi konsol şifresi açık bir şekilde gözükmektedir.

3-) Şifre görünümünü şifrelemek için aşağıdaki komutları uyguluyoruz;

conf term
service password-encryption
exit
write memory

4-) Evet tekrar enable mod üzerinden aşağıdaki komutu uyguladığımızda şifremiz şifrelenmiş bir şekilde gözükecektir.

show startup-config

5-) Bu işlemden sonra Packet Tracer üzerinden konsol kablosu ile bağlantı yapmayı deneyelim. Gerekli bağlantıları yaptıktan sonra bilgisayar masaüstünden Terminal yazan yere tıklıyoruz.

6-) Açılan bölümden konfigürasyonu aynı şekilde bırakıyoruz ve Ok butonuna tıklıyoruz.

7-) Gelen ekranda da gözüktüğü gibi cihaza bağlanmak için şifre girmemiz gerekmektedir. Tanımladığımız konsol şifresini girdiğimizde cihaza erişebiliyor olduk.

Cisco ile ilgili konularımıza devam edeceğiz. Bizi takip etmeye devam edin.

WordPress Toplu Yorum Silme

WordPress ile oluşturduğumuz web sitemizde biriken spam yorumları admin panel üzerinden silmek uzun süre gerektiren, sıkıntılı bir süreçtir. Bu nedenden dolayı bu işlemi admin panel üzerinden yapmak yerine veritabanı servisini kullanarak sadece bir satırlık sql sorgusu ile kolay bir şekilde yapabiliriz. Fakat bu işlemi yapmak için mysql servisine (phpMyAdmin) erişebilir durumda olmamız gerekmektedir. Bu servise hosting kontrol panelleri üzerinden kolay bir şekilde erişebiliriz.

WordPress’te toplu yorum silmek için uygulamamız gereken işlemler şu şekildedir;

Not: Bu işlemi yapmadan önce web sitemizin full yedeğini (dosyalar, veritabanı vb.) almamız gerekmektedir. Yaşanabilecek sıkıntılı bir durumda veri kaybı yaşayabiliriz. Ayrıca konu ile ilgili bilginiz yoksa bu işlem için uzman bir kişiden destek almanızı öneririz. Bu uyarıları göz önünde bulundurarak işlem yapmanızı öneririz.

1-) İlk olarak web sitemizin barındığı hosting kontrol paneline (Cpanel, Plesk Panel vb) giriş yapıyoruz.

2-) Hosting kontrol panelinde veri tabanı bölümünden phpmyadmin servisine giriş yapıyoruz.

3-) Gelen ekranın sol tarafından web sitemizin veri tabanının üstüne tıklıyoruz.

4-) Açılan ekranın üst tarafından SQL yazan yere tıklıyoruz.

5-) Gelen ekrandaki veri girilecek alana aşağıdaki sql sorgusunu yazıp Git butonuna bastığımızda onaylanmamış olan yorumların tamamı silinmiş olacaktır;

DELETE from wp_comments WHERE comment_approved = '0';

6-) Eğer onaylanmış yorumları da silmek istiyorsak komutta 0 yazan yere 1 yazmamız yeterli olacaktır. Yani aşağıdaki komutu uygulamamız yeterlidir;

DELETE from wp_comments WHERE comment_approved = '1';

Evet WordPress’te toplu yorum silme işlemi bu kadar. Tekrar görüşmek üzere. Şimdilik hoşçakalın.

Cisco VRRP Konfigürasyonu

VRRP kısaca, network ortamında yönlendirici (router) yedekliliğini sağlayan bir protokoldür. Bu protokol sayesinde network ortamında birden fazla yönlendiriciyi tek bir yönlendirici gibi gösterebilmemiz mümkündür. Bu protokol ayrıca network trafiğinin birden fazla yönlendirici (router) üzerine dağıtarak yük paylaşımı yapılmasına da olanak sağlar.

Cisco cihazlarda bu protokolü aktif yapmak için uygulanması gereken adımları bu yazıda detaylı bir şekilde öğreneceğiz. Bu işlemi örnek yapı üzerinden anlatacağız. Aşağıdaki görselden örnek yapımızı inceleyebilirsiniz.

İlk olarak Router0 üzerinden aşağıdaki komutları uyguluyoruz;

enable
conf term
int gig0/0/0
no shutdown
ip address 192.168.1.1 255.255.255.0
vrp 10 ip 192.168.1.1
vrp 10 priority 200
vrp 10 preempt

Daha sonra Router1 üzerinden aşağıdaki komutları uyguluyoruz;

enable
conf term
int gig0/0/0
no shutdown
ip address 192.168.2.1 255.255.255.0
vrp 10 ip 192.168.1.1
vrp 10 priority 150

Şimdi bu komutları kısaca anlatalım. Burada vrp komutundan sonra uyguladığımız 10 değeri grup numarasıdır. Bu bölüme 1-255 arasında bir değer atayabiliriz. Bu değer vrrp aktif yapacağımız routerlarda aynı olması gerekmektedir. Bu şekilde routerları aynı vrrp protokolünde gösterebiliriz. Ayrıca burada kullandığımız priority değeri önceliği belirtmektedir. Bu bölüme de 1-254 arasında bir değer atayabiliriz. Değeri yüksek olan router üzerinden trafik akışı gerçekleşir. Yani master (birinci) router olarak tanımlanmış olunur (trafik akışı ilk olarak bu router üzerinden gerçekleşir). Bu işlemleri uyguladıktan sonra router0 devre dışı kaldığında çok kısa bir kesintiden sonra trafik akışı router1 üzerinden devam edecektir. Akış her zaman 192.168.1.1 ip üzerinden olacaktır. Çünkü burada sanal ip adresini 192.168.1.1 olarak seçtik.

Not: Dikkat ettiyseniz Router0 üzerinden ekstradan vrp 10 preempt komutunu uyguladık. Bu komutun işlevi şu şekildedir. Ne demiştik router0 da bir kesinti olduğunda yük akışı router1 üzerinden devam edecekti. Bu komut Router0’daki kesinti nedeni ortadan kalktığında trafik akışının otomatik olarak tekrar bu router (Router0) yani master router üzerinden devam etmesini sağlamış olduk.

Cisco ile ilgili konularımıza devam edeceğiz. Bizi takip etmeye devam edin.

Linux Disk Bölümleme

Linux işletim sistemlerinde fdisk kullanarak kolay bir şekilde disk bölümlemesi yapabiliriz. Bu yazıda bu işlemin nasıl yapılacağını detaylı bir şekilde anlatacağız.

Linux’ta Disk Bölümleme Nasıl Yapılır?

Bu işlemin adımları genel olarak aşağıdaki gibidir;

1-) Linux’ta disk bölümleme işlemi root yetkisi gerektiğinden dolayı ilk olarak aşağıdaki komutu uygulayarak root yetkisine sahip oluyoruz;

sudo su
veya
su

Bu komuttan sonra bizden root şifresi istenecektir. Root şifresini girdikten sonra root yetkisine sahip olacağız. Artık her komutta sudo veya su komutunu uygulamamıza gerek kalmayacaktır.

2-) İlk olarak sistemimizde yer alan diskleri ve disk bölümlerini ağaç yapısında görüntülemek için lsblk komutunu uyguluyoruz;

Disklerimiz sda, sdb şeklinde gözükecektir. Disk bölümleri (partiton) ise sda1, sda2, sdb1 şeklinde gözükecektir. Bu isimlendirme yapınıza göre değişebilir. Görselde de gözüktüğü gibi bizim sdc isminde 4 GB’lık bölümlenmemiş bir diskimiz bulunmaktadır. Bu diski bölümlendireceğiz.

3-) Fdisk kullanarak disk bölümlendirmek için ilk olarak aşağıdaki komutu uyguluyoruz;

fdisk /dev/sdc

Bu komuttan sonra bizden birkaç bilgi istenerektir. Bu bilgiler;

Command (m for helped): Bu bölümü n tuşuna basıp enter yaparak geçiyoruz.
Partition number: P (primary partition) tuşuna basıp enter yapıyoruz.
Partition number: Bu bölümü enter yaparak geçebiliriz. Bu bölümden partitionu numaralandırabiliriz (sdc1, sdc2). Boş bıraktığımızda default olarak bir değer atanır (Bizim örneğimizde partition ismi sdc1 olacaktır).
First sector: Enter yaparak geçiyoruz.
Last sector: Partition boyutunun ne olmasını istiyorsak burada belirtiyoruz. Boş bırakıp enter yaparsak boştaki tüm alan kullanılacaktır. Biz tüm alanı kullanacağımız için bir değer yazmadan enter yapıyoruz. Eğer 2GB’lık bir alan kullanmak isteseydik +2G yazıp enter yapmamız yeterli olacaktı.
Command (m for helped): Yaptığımız değişiklikleri kaydetmek için bu bölümde w tuşuna basıp enter yapıyoruz.

4-) Oluşturduğumuz partitionu görüntülemek için tekrar lsblk komutunu uyguluyoruz.

5-) Oluşturduğumuz partitionu Linux disk yapısında biçimlendirmek için aşağıdaki komutu uyguluyoruz;

mkfs.ext4 /dev/sdc1

6-) Son olarak partitionu kullanmak için mount işlemini yapıyoruz. Bu işlem için ilk olarak bulunduğumuz konumda yenidisk isimli bir klasör oluşturuyoruz ve bu klasör içine partitionu mount ediyoruz. Bu işlem için aşağıdaki komutları uygulamamız yeterli olacaktır;

mkdir yenidisk
mount /dev/sdc1 yenidisk

Evet artık partitionu kullanabiliriz. Tekrar görüşmek üzere.

Centos Selinux Kapatma

Selinux, Linux çekirdeği ile oluşturulmuş işletim sistemlerinin çoğunda entegre olarak bulunan bir güvenlik kontrol servisidir. Bu servis bazı uygulamaların çalışmasını engelleyebilir. Seliux’un aktif olması hosting kontrol panellerinin kurulumu sırasında veya başka servislerin çalıştırılmasında sorun çıkarabilmektedir. Bu durumda Selinux’u devre dışı bırakmamız gerekmektedir. Centos işletim sistemlerinde Selinux’u devre dışı
bırakmak için yapılması gereken işlemleri bu yazıda öğreneceğiz;

1-) Bu işlemi yapmak için root yetkisine sahip olmamız gerekmektedir. Bunun için ilk olarak aşağıdaki komutu uyguluyoruz ve root şifremizi giriyoruz;

su

Direkt root olarak bağlantı yaptıysak bu aşamayı uygulamamıza gerek yoktur.

2-) Daha sonra aşağıdaki komutu uygulayarak selinux ayarlarının yer aldığı dosyayı açıyoruz;

nano /etc/selinux/config

3-) Açılan dosyanın içinden;

SELINUX=enforcing yazan yeri SELINUX=disabled olarak değiştiriyoruz ve dosyayı kaydetmek için önce CTRL + X tuşlarına birlikte basıyoruz. Daha sonra Y tuşuna basıp enter yapıyoruz.

Bu işlemlerden sonra Selinux kapanmış olacaktır. Tekrar görüşmek üzere. Şimdilik hoşçakalın.

Cisco Switch ve Router üzerinde SSH Açma

Network ortamında Cisco cihazlara uzaktan bağlantı yapmak istediğimizde telnet ve ssh servislerinden birini kullanabiliriz. Telnet servisinde iletişim şifrelenmeden gerçekleştiği için güvenli bir bağlantı sağlanamaz. Ssh bağlantıda ise iletişim şifreli olarak gerçekleştiği için bağlantı güvenli olmaktadır. Bu nedenden dolayı uzaktan bağlantı yapmak için ssh servisini kullanmamız doğru olacaktır.

Daha önceki yazılarımızda Cisco cihazlarda ssh servisinin temel olarak nasıl aktif
yapabileceğimizi anlatmıştık. Bu yazıda ise bu işlemi daha detaylı bir şekilde anlatacağız. Bu işlemi anlatmak için örnek bir yapı oluşturacağız. Örnek yapımızda switchte ssh servisini aktif yaparak sadece bir ip adresin ssh bağlantı yapmasına izin verip güvenliği üst seviyede tutacağız. Bu işlemi access list kuralı yazarak yapacağız. Şimdi işlemlerimizi geçelim. Yapımızı aşağıdaki görselden inceleyebilirsiniz.

Yapımızda bir adet switch ve iki adet bilgisayar bulunmaktadır. Switch ve bilgisayarların ip bilgileri şu şekildedir;

Switch: 10.0.0.1/8
Pc1:10.0.0.2/8
Pc2:10.0.0.3/8

Yapımızda switchte ssh servisini aktif yaparak sadece 10.0.0.2 ip adresli bilgisayarın ssh bağlantısı yapmasına izin vereceğiz. Bu şekilde şifre denemesi ile bağlantı yapılma ihtimalini bile engellemiş olacağız. Şimdi switch üzerinde yapılacak işlemlere geçelim;

1-) İlk olarak switchte hostname tanımlaması yapıyoruz ve enable moda şifre veriyoruz;

enable 
conf term
hostname bilgialnet
enable secret 12345

2-) İkinci adımda switche ip adresi tanımlaması yapıyoruz;

interface vlan 1
ip address 10.0.0.1 255.0.0.0
no shutdown
exit

3-) Switche başarılı bir şekilde ip adresi tanımladık. Şimdi switchte bir hesap oluşturacağız. Bu hesap ssh bağlantısı yapabilecek. Ayrıca switchte domain name tanımlaması da yapacağız. Son olarak ta ssh bağlantısı için bir anahtar oluşturacağız. Bu anahtarı 1024 bit olarak ayarlayacağız. Bu işlemler için aşağıdaki komutları uygulamamamız yeterli olacaktır;

username onur password 54321
service password-encryption
ip domain-name bilgialnet.com
crypto key generate rsa
1024

4-) İşlemimizi tamamlamak üzereyiz. Bu aşamada ssh bağlantısını aktif yaparak, aynı anda bağlantı yapabilecek kullanıcı sayısını tanımlıyoruz. Bu işlem için uygulamamız gereken komutlar şu şekildedir;

line vty 0 4
transport input ssh 
login local
exit

5-) Artık ssh bağlantısı yapabiliriz. Fakat bu şekilde kısıtlama olmadan networke bağlı tüm bilgisayarlar ssh bağlantı yapma isteği bulunabilir. Bunu engellemek için switch üzerinde bir adet access list yazıyoruz;

ip access-list standard sshizin
permit host 10.0.0.2
exit
line vty 0 4 
access-class ssh izin in
exec-timeout 10
exit

Bu komutlar ile sshizin isimli bir access list oluşturmuş olduk. Bu access listte sadece 10.0.0.2 ip adresin erişim yapabileceği bir izin verdik ve daha sonra ssh bağlantısında bu kuralı gösterdik. Ayrıca burada exec-timeout 10 komutu ile ssh bağlantıda bekleme süresini 10 saniye olarak belirlemiş olduk.

6-) Bilgisayarlara ip tanımlaması yaptıktan sonra switche ssh ile bağlanmayı deneyelim. Bunun için Packet Tracer’da 10.0.0.2 ip adresli bilgisayarın masaüstünden Tlenet/SSH Client yazan yere giriyoruz.

7-) Açılan ekrandan gerekli alanları dolduruyoruz.

😎 Görselde de görüldüğü gibi switche başarılı olarak bağlandık. 10.0.0.3 ip adresli bilgisayardan aynı işlemi denediğimizde switch erişimi başarısız olacaktır.

Cisco cihazlarda ssh açma işlemi bu kadar. Bu konu ile ilgili sorularınızı yorum bölümünden bizlere iletebilirsiniz.